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The timestamps on logs for domains do not correspond to the global System time zone

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • The time zone in Tools & Settings > System Time > Time Zone is configured to Europe/Madrid (for the purpose of this example)

  • At the same tine, at Domains > example.com > Logs show Access Logs with UTC timestamps and only Apache logs appear with Europe/Madrid timestamps

Cause

This issue is tied to a known bug with ID #PPPM-14021, which will be resolved in future versions of Plesk.

You may track the progress in the Change Log for Plesk Obsidian.

Resolution

Until the bug is resolved permanently, you may execute the following workaround:

  1. Connect to the server via SSH

  2. Edit the file /usr/local/psa/admin/conf/php.ini with your favorite command-line text editor

  3. In order to apply the timezone from Tools & Settings > System Time > Time Zone to the remaining log files, you must append the following line:

    CONFIG_TEXT: date.timezone = Europe/Madrid

  4. Restart the sw-engine service:

    # systemctl restart sw-engine

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