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Unable to configure a mailbox on the Plesk server in Outlook: Unable to connect to the SMTP server: connection timed out.

kb: technical ext: sslit

Symptoms

  • Unable to configure a mailbox hosted on the Plesk server in Outlook / mobile mail clients.

  • The following error appears in /var/log/maillog during the connection attempt:

    Jun 6 22:49:25 example dovecot[85614]: service=imap, user=plesktest@example.com, ip=[127.0.0.1]. Disconnected: Connection closed (IDLE running for 0.001 + waiting input for 0.000 secs, 2 B in + 10+10 B out, state=wait-input) rcvd=11, sent=461
    o address 1.2.3.4: Name or service not known
    Jun 6 22:49:25 example postfix/smtpd[86816]: connect from unknown[1.2.3.4]
    Jun 6 22:49:25 example postfix/smtpd[86816]: SSL_accept error from unknown[1.2.3.4]: -1
    Jun 6 22:49:25 example postfix/smtpd[86816]: warning: TLS library problem: error:14209102:SSL routines:tls_early_post_process_client_hello:unsupported protocol:ssl/statem/statem_srvr.c:1686:

  • TLSv1.2 is already enabled:

    # grep ssl_min /etc/dovecot/conf.d/11-plesk-security-ssl.conf
    ssl_min_protocol=TLSv1.2

  • Checking the website on sslabs.com returns error for TLS1.2:

  • TLS versions and ciphers by Mozilla under Tools & Settings > TLS versions and ciphers management > Settings are outdated:

Cause

Outlook version does not support TLS 1.3 ciphers and TLS 1.2 is disabled on the Plesk server.

Resolution

  1. Log into Plesk

  2. Navigate to Tools & Settings > TLS versions and ciphers management > Settings

  3. Update ciphers by clicking on Sync Now button.

  4. Reconfigure Outlook

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