Articles in this section

Error on adding a server to Plesk 360: The token is invalid possibly because the server time differs from the world time

Plesk 360

Symptoms

  • One of the following errors appears on attempts to add the server to Plesk 360:

    CONFIG_TEXT: The token is invalid possibly because the server time differs from the world time


    CONFIG_TEXT: The token has expired due to a delay in adding or the server time differs from the world time.


    PLESK_ERROR: The token has expired.


    PLESK_ERROR: Unexpected error: JWT token is not signed by trusted issuer: https://platform360.io/.well-known/jwks.json

  • In /var/log/plesk/panel.log with debug one of the following errors is shown:

    CONFIG_TEXT: [2021-10-22 21:58:15.919] ERR [extension/platform360] Cannot handle token prior to 2021-10-22T21:58:21+0200


    CONFIG_TEXT: ERR [extension/platform360] Expired token

Cause

Due to the time difference on a server and https://platform360.io server token does not work properly.

Resolution

Change time on the server to be synced with global time and enable synchronization:

  1. Log into Plesk

  2. Go to Tools & Settings > System Time

  3. Set the timezone

  4. Tick the checkbox Synchronize system time and specify the time server

    Note: If the server is running Debian 10/Ubuntu 20/CentOS 8/AlmaLinux 8/RHEL 8 (that have a built-in timesyncd component) the section Network time does not appear. In that case, the time synchronization should be adjusted on the OS level.

  5. Click OK

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.