Articles in this section

Not possible to connect server to Plesk 360: The server has an invalid certificate

DoNotDelete:docref Plesk 360

Symptoms

  • Unable to add a server to Plesk 360 with one of the errors below:

    PLESK_ERROR: The server has an invalid certificate


    PLESK_ERROR: Hostname/IP does not match certificate's altnames


    PLESK_ERROR: A self-signed certificate is installed


    PLESK_ERROR: The certificate has expired

  • The hostname without a valid certificate or the IP address (i.e. https://213.0.1.2:8443) is used to connect the server to Plesk 360

Cause

Plesk URL used to connect the server is not secured by a valid certificate.

Resolution

  1. Check if any related hostname is secured with an existing certificate under Tools & Settings > SSL/TLS certificates > Certificate for securing Plesk.

    Note: That might be verified by using external resources as well - such as Qualsys SSL Labs, SSL Shopper.

    If the certificate is presented and valid, use the related hostname:

    • specify https://server.hostname.com:8443 on adding the server to Plesk 360
    • access the Plesk UI via https://server.hostname.com:8443 and add the server to Plesk 360 from there
  2. If there is no valid certificate, use the below article to secure Plesk URL:
    How to secure a Plesk hostname on port 8443 with an SSL certificate (Let's Encrypt / other certificate authorities)
Was this article helpful?

Comments

2 comments
Date Votes
  • I can't get the organization name to match the ssl name so I get an error.

    0
  • The server name in the list at plesk 360 is incorrect and there doesn't seem to be any way to change it. The certificate is in correct because the information at plesk 360 is incorrect.

    0

Please sign in to leave a comment.