Symptoms
-
Unable to add a server to Plesk 360 with one of the errors below:
PLESK_ERROR: The server has an invalid certificate
PLESK_ERROR: Hostname/IP does not match certificate's altnames
PLESK_ERROR: A self-signed certificate is installed
PLESK_ERROR: The certificate has expired
-
The hostname without a valid certificate or the IP address (i.e.
https://213.0.1.2:8443) is used to connect the server to Plesk 360
Cause
Plesk URL used to connect the server is not secured by a valid certificate.
Resolution
-
Check if any related hostname is secured with an existing certificate under Tools & Settings > SSL/TLS certificates > Certificate for securing Plesk.
Note: That might be verified by using external resources as well - such as Qualsys SSL Labs, SSL Shopper.
If the certificate is presented and valid, use the related hostname:
- specify
https://server.hostname.com:8443on adding the server to Plesk 360 - access the Plesk UI via
https://server.hostname.com:8443and add the server to Plesk 360 from there
- specify
- If there is no valid certificate, use the below article to secure Plesk URL:
How to secure a Plesk hostname on port 8443 with an SSL certificate (Let's Encrypt / other certificate authorities)
Comments
I can't get the organization name to match the ssl name so I get an error.
The server name in the list at plesk 360 is incorrect and there doesn't seem to be any way to change it. The certificate is in correct because the information at plesk 360 is incorrect.
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