Applicable to:
- Plesk for Linux
Symptoms
-
When creating a domain/subscription or enabling the mail service for a domain, the operation fails with one of the following error messages:
An error occurred during domain creation: mailmng-outgoing failed: ERROR:outgoing:column name is not unique
mailmng-outgoing failed: ERROR:__main__:database is locked
Error: mailmng-outgoing failed: ERROR:__main__:UNIQUE constraint failed: domains.name
Configuring mail
mailmng-outgoing failed: ERROR:__main__:PRIMARY KEY must be unique
Configuring mail
Task is not responding: id=3315, pid=2251, type=domain-create, clientRemoteAddr=203.0.113.2, current_stage=Mail, ...
mailmng-outgoing failed: ERROR:__main__:no such table: mails
-
Migration of a domain to Plesk finishes with the following warning and the domain is created with No Hosting type:
Failed deployment of domain example.com
Warning:
...
Stderr is An error occurred during domain creation: mailmng-outgoing failed: ERROR:outgoing:column name is not unique
Cause
Product issue:
-
#PPPM-13825 "Fixed an issue where, if domain creation failed after the outgoing mail settings had been applied, those settings were not rolled back, so that creating a domain with the same name again failed with the âcolumn name is not uniqueâ error."
Fixed in:- Plesk Obsidian 18.0.81 15 September 2026 (Linux)
Resolution
Workaround
If update is not possible for some reason you may try the following
-
Connect to the (destination) Plesk server via SSH.
-
Rename the database:
# mv /var/lib/plesk/mail/outgoing/data.db{,_bk}
-
Rebuild the outgoing mail control database:
-
on CentOS/RHEL-based distributions:
# /usr/lib64/plesk-9.0/remote_mail_restore/mail_outgoing_restore
-
on Debian/Ubuntu-based distributions:
# /usr/lib/plesk-9.0/remote_mail_restore/mail_outgoing_restore
-
Note: In case of failed migration, re-sync subscription. In other cases, recreate or reenable the object that was returning the error.
Comments
Please sign in to leave a comment.