Applicable to:
- Plesk for Windows
Symptoms
-
Plesk and websites are unavailable with the following error message in a web-browser:
PLESK_INFO: 503 Service unavailable.
-
Application pools are stopped in IIS Manager > Application pools.
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After restarting an application pool of the website and accessing this website, the application pool crashes.
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The following error message is logged in Windows Event Viewer > Windows Logs > Application:
PLESK_INFO: The Module DLL C:\path\to\module_name.dll failed to load. The data is the error.
Cause
The module defined in IIS configuration is improperly configured.
Resolution
-
Connect to the Plesk server via RDP.
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Create a backup of IIS configuration:
C:\> %windir%\system32\inetsrv\appcmd.exe add backup BeforeEditBackup
Note: The backup will be created in
C:\Windows\System32\inetsrv\backup
. -
Start Internet Information Services (IIS) Manager at Windows Start > All Programs > Administrative Tools.
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In IIS Manager, click on SERVERNAME > Modules and remove the faulty module reported in the error message.
Note: In case the module is not visible on the modules page, move to step 6.
-
Open the file
%windir%\system32\inetsrv\config\ApplicationHost.config
in a text editor and remove the lines related to the faulty module (if exist).
For example:CONFIG_TEXT: <add name="CSPms" image="C:\Inetpub\CSPGateway\CSPms.dll" />
-
Save the changes.
-
Restart IIS:
C:\> iisreset
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