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"The target principal name is incorrect" warning shown in Outlook when connecting account hosted on Plesk server

kb: technical ABT: Group A

Symptoms

  • While configuring Outlook mail client, the pop-up warning appears:

    CONFIG_TEXT: The target principal name is incorrect

  • When check the certificate via View Certificate... it shows incorrect certificate:

    CONFIG_TEXT: This CA Root certificate is not trusted. To enable trust, install this certificate in the Trusted Root Certification Authorities store.

  • The correct SSL certificate is installed for Mail Server at Tools & Settings > SSL/TLS Certificates > Certificate for securing mail [change].

  • The secured mail server name is used in Outlook account settings as Incoming and Outgoing mail server names.

Cause

By the "target principal name", Outlook means the CN (canonical name) from the SSL certificate that is installed on the Plesk server. For some reason, in some cases Outlook decides to look for mail.example.com, when the canonical name set on the side of the server is example.com, due to which it's throwing a mismatch error.

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > SSL/TLS Certificates > Certificate for securing mail [change] and click Apply to re-apply the mail server certificate.

Afterwards, you should attempt to add the mailbox to Outlook from scratch.

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