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Mail is not forwarded to destination address if forwarding source mail address has reached mailbox size limit and its mailbox was turned off subsequently

kb: bug Plesk Obsidian for Linux ABT: Group B Plesk Onyx 17.5 for Linux

Applicable to:

  • Plesk Obsidian for Linux
  • Plesk Onyx 17.5 for Linux

Symptoms

  • destination@example.com is set up as forwarding destination mail address in Domains > example.com > Email Addresses > source@example.com;
  • source@example.com has reached its mailbox size limit;
  • Mailbox for mail address source@example.com was turned off in Domains > example.com > Email Addresses > source@example.com;
  • After that mail is not delivered to the destination@example.com with the following error in /var/log/maillog:

    CONFIG_TEXT: Mar 13 13:01:09 ppu17-5 postfix/smtpd[6797]: connect from localhost[::1]
    Mar 13 13:01:09 ppu17-5 postfix/smtpd[6797]: 7842561C3AA3: client=localhost[::1], sasl_method=DIGEST-MD5, sasl_username=sender@example.com
    Mar 13 13:01:09 ppu17-5 postfix/cleanup[6801]: 7842561C3AA3: message-id=<47661669ceb88b53fa04f23356a1330f@example.com>
    Mar 13 13:01:09 ppu17-5 check-quota[6803]: Starting the check-quota filter...
    Mar 13 13:01:09 ppu17-5 /usr/lib64/plesk-9.0/psa-pc-remote[15087]: handlers_stderr: DATA REPLY:452:4.2.2 Mailbox full#012DEFER
    Mar 13 13:01:09 ppu17-5 /usr/lib64/plesk-9.0/psa-pc-remote[15087]: DEFER during call 'check-quota' handler
    Mar 13 13:01:09 ppu17-5 postfix/cleanup[6801]: 7842561C3AA3: milter-reject: END-OF-MESSAGE from localhost[::1]: 4.2.2 Mailbox full; from=<sender@example.com> to=<source@example.com> proto=ESMTP helo=<webmail.example.com>

  • The same error appears in logs if destination@example.com is disabled but its folder remains on the file system at /var/qmail/mailnames/example.com/destination/ and its size reached the mailbox limit set previously in Domains > example.com > Email Addresses > destination@example.com:

    MailboxQuota.jpg

    # du -sh /var/qmail/mailnames/example.com/destination/
    105M /var/qmail/mailnames/example.com/destination/

Cause

The issue is caused by bug with ID #PPPM-10245, which is planned to be fixed in product future updates.

Resolution

As workaround, 

  1. Log into Plesk
  2. Switch Mailbox back on for the email source@example.com (or for destination@example.com depends on whichever is limited) in Domains > eample.com > Email Addresses.

    Note: After re-enabling the mailbox, either free space or increase the mailbox limit

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