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Emails are stuck in queue on a Plesk for Linux server with Plesk Email Security installed: delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

Plesk for Linux kb: technical ext: pes

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk Email Security extension is installed.

  • Emails are stuck in mail queue. The following error messages is logged in /var/log/maillog:

    CONFIG_TEXT: name postfix/error[14531]: 8954F66E14A4: to=jdoe@example.com, relay=none, delay=25755, delays=25754/0.07/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

  • Amavis service is stopped shortly after activation. One of the the following error messages appear either in service status or system log /var/log/syslog:

    # systemctl status amavisd
    (...)
    systemd[1]: Starting Amavis mail content checker...
    name amavisd[1507]: The value of variable $myhostname is "name", but should have been
    name amavisd[1507]: a fully qualified domain name; perhaps uname(3) did not provide such.
    name amavisd[1507]: You must explicitly assign a FQDN of this host to variable $myhostname
    name amavisd[1507]: in amavisd.conf, or fix what uname(3) provides as a host's network name!


    # systemctl status amavis
    (...)
    name amavis[1108]: Starting amavisd: The value of variable $myhostname is "name", but should have been
    name amavis[1108]: a fully qualified domain name; perhaps uname(3) did not provide such.
    name amavis[1108]: You must explicitly assign a FQDN of this host to variable $myhostname
    name amavis[1108]: in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    name amavis[1108]: network name!
    name amavis[1108]: (failed).

Cause

The server hostname defined in Amavis configuration is not a fully qualified domain name (FQDN) or is not defined at all.

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > Server Settings and in Full hostname field

  3. Set a fully qualified domain name (FQDN) that resolves to IP address of your Plesk server.

  4. Click OK.

  5. Connect to your Plesk server via SSH.

  6. Set a valid hostname in the system. Replace server.example.com with a hostname defined in Plesk:

    # hostnamectl set-hostname server.example.com

  7. Start amavis service:

    # service amavis restart

  8. Restart Postfix service:

    # service postfix restart

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