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The default certificate is used for IMAP connection when the Plesk Premium Mail is installed

kb: technical

Symptoms

  • The default certificate is used for IMAP (993) connection when the Plesk Premium Mail is installed in Extensions > My Extensions:

    # openssl s_client -showcerts -connect exmple.com:993 -servername example.com | grep CN
    ... O = Plesk, CN = Plesk, emailAddress = info@plesk.com

  • But SMTPS (465) connections are secured with correct SSL taken from Domains > example.com > Mail Settings:

    # openssl s_client -showcerts -connect exmple.com:465 -servername example.com | grep CN
    ...CN = example.com

Cause

SNI configuration was broken for domain example.com

Resolution

  1. Log into Plesk.

  2. Go to Subscriptions > example.com > Customize and temporary enable the options below in case they are not enabled:

    • Plesk Premium Mail
    • Plesk Premium Mail - Free
  3. Go to Subscriptions > example.com > Plesk Premium Email and press the button Fix.

    Note: This step can also be performed directly via Plesk > Premium Email > example.com > Click on the arrow to open the additional information

  4. If Plesk Premium Email should not be used for example.com, disable it's settings back in Subscriptions > example.com > Customize:

    • Plesk Premium Mail
    • Plesk Premium Mail - Free
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Comments

1 comment
Date Votes
  • If the Fix button is missing, this command will have the same effect:

    plesk bin extension -e kolab sync-guam-config.php
    1

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