Symptoms
-
Big Server Backup finishes with:
CONFIG_TEXT: Unable to create the remote backup: Transport error: Extension transport: ext://google-drive-backup/server/: Google Drive returns an error. Please try repeating the operation later. The error details:
-
With Plesk and pmmcli-rc in debug mode, the following is shown in
/var/log/plesk/PMM/backup-TIMESTAMP/backup.log file
CONFIG_TEXT: [2022-05-10 22:53:19.902|14269] INFO: TransportError Transport error: Extension transport: ext://google-drive-backup/server/: The file My Drive/Server-01/Full_Backup is not found [common/plesk-utils/PMM/repository-transport/repository_transport_external.cpp:TransportError]
void plesk::RepositoryTransportExternal::HandleHelperExitCode(plesk::tLogExecCmd&)
[2022-05-10 22:53:19.902|14269] INFO: RepositoryError Repository error: file backup_2205100136.tar not exists [common/plesk-utils/PMM/repository-transport/repository.cpp:RepositoryError]
virtual void plesk::tRepository::DeletePackedBackup(const string&)
[2022-05-10 22:53:19.903|14269] INFO: pmm-ras finished. Exit code: 151
Cause
Full Backup upload takes long time to complete, so Google Drive Timeout triggers and removes the file
Resolution
Enable Multivolume backup in Scheduled Backup Settings under Tools & Settings > Backup Manager > Schedule.
Note: Side effect = Backup should finish quicker since it won't need to wait for the full backup to start the upload.
Note: More API calls will be needed, since there will be uploads of more files than just 1 full backup.
.
Comments
0 comments
Please sign in to leave a comment.