Applicable to:
- Plesk for Linux
Symptoms
-
Websites are intermittently unavailable. Web browser shows the error immediately upon accessing a website.
-
Nginx or Apache service is frequently restarted, below information can be found in
/var/log/plesk/rc_actions.log
:CONFIG_TEXT: INFO: Service: httpd, Action: stop
INFO: Service: httpd, Action: status
INFO: Service: httpd, Action: start -
The following records can be found in
/var/log/syslog
(Debian/Ubuntu),/var/log/messages
(CentOS/CloudLinux/RHEL), or/var/log/monit.log
:CONFIG_TEXT: 'nginx' failed protocol test [generic] at INET[203.0.113.2:80].
'nginx' trying to restart
'nginx' stop: /opt/psa/admin/bin/nginx_control
'nginx' start: /opt/psa/admin/bin/nginx_controlCONFIG_TEXT: GENERIC: error receiving data -- Resource temporarily unavailable
'apache' failed protocol test [generic] at INET[203.0.113.2:80].
'apache' trying to restart
'apache' stop: /usr/local/psa/admin/bin/websrvmng
'apache' start: /usr/local/psa/admin/bin/websrvmng
'apache' connection passed
Cause
Nginx or Apache is being restarted by Watchdog due to the false-negative protocol test.
This is likely to happen due to the short connection timeout value.
Resolution
-
Increase Connection timeout value for nginx in Extensions > My Extensions > Watchdog > Web Proxy Server (Nginx):
Or increase Connection timeout value for Apache in Extensions > My Extensions > Watchdog > Open > Web Server (Apache):
Comments
0 comments
Please sign in to leave a comment.