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Email delivery delay: 4.7.1 Service unavailable - try again later

Plesk for Linux kb: technical mail

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk hosted mailboxes receive emails long after they were sent, including mailing list messages.

  • Greylisting is enabled in Tools & Settings > Spam Filter

  • Some of these messages are logged to /var/log/maillog:

    milter-reject: DATA from mail.example.com[203.0.113.2]: 451 4.7.1 Service unavailable - try again later

    milter-reject: DATA from unknown[203.0.113.2]: 550 5.7.1 Command rejected

    milter-reject: DATA from localhost[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; from=mailinglist-bounces@example.com

    Additional logs

    handlers_stderr: DEFER
    DEFER during call 'grey' handler
    Message aborted.
    milter-reject: DATA from mail.example.com[203.0.113.2]: 451 4.7.1 Service unavailable - try again later; from=jdoe@example.com to=jdoe@example.org proto=ESMTP helo=<mail.example.com>

    greylisting filter[10489]: Starting greylisting filter...
    /usr/lib64/plesk-9.0/psa-pc-remote[8641]: handlers_stderr: REJECT
    /usr/lib64/plesk-9.0/psa-pc-remote[8641]: REJECT during call 'grey' handler
    /usr/lib64/plesk-9.0/psa-pc-remote[8641]: Message aborted.
    reply: SMFIR_REJECT data 0 bytes
    milter-reject: DATA from unknown[203.0.113.2]: 550 5.7.1 Command rejected; from=jdoe@example.com to=jdoe@example.org proto=ESMTP helo=<mail.example.com>

    In /var/log/mailman/smtp-failure:

    (2430) delivery to jdoe@example.org failed with code 451: 4.7.1 Service unavailable - try again later

Cause

This behavior is expected when greylisting is enabled. Greylisting helps filter unwanted email by temporarily rejecting messages from new senders.

When this feature is enabled, the first message from any sender is rejected. Their address is temporarily added to a list, and all their future messages are accepted only after their list entry expires. If they try to send another message before then, there will be an additional waiting period.

Resolution

Each of the following options will either reduce or eliminate delays.

  • Decrease the greylisting interval as described in How do I configure greylisting?

  • Whitelist the affected addresses or domains in Tools & Settings > Spam Filter > White List. For mailing lists, whitelist the list domain.

  • Disable greylisting in Tools & Settings > Spam Filter. Note that this will reduce spam protection.

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