Articles in this section

Mail from Plesk server is rejected with error: 550-5.7.1 is likely unsolicited mail

Plesk for Windows Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Mail forwarded to Gmail is rejected:

    CONFIG_TEXT: Our system has detected that this message
    550-5.7.1 is likely unsolicited mail. To reduce the amount of spam sent to
    550-5.7.1 Gmail, this message has been blocked. Please visit 550-5.7.1
    http://support.google.com/mail/bin/answer.py?hl=en&answer=188131 for 550
    5.7.1 more information. ho13si622251wib.49 - gsmtp (in reply to end of DATA
    command)


    CONFIG_TEXT: MailEnable: Message could not be delivered to some recipients.
    The following recipient(s) could not be reached:
    Recipient: [SMTP:john.doe@example.com]
    Reason: Remote SMTP Server Returned: 550 See http://spf.pobox.com/why.html?sender=***(#5.7.1)

  • The following error log can be found in /var/log/maillog :

    CONFIG_TEXT: postfix/smtp[4907]: 02A25158106B: to=<john.doe@example.com>, relay=mx1.example.com[203.0.113.2]:25, delay=22, delays=0.45/0.04/10/12, dsn=5.7.1, status=bounced (host mx1.example.com[203.0.113.2] said: 550 5.7.1 <john.doe@example.com>: Recipient address rejected: Please see http://www.openspf.net/Why?s=helo;id=example1.com;ip=203.0.113.3;r=mx1 (in reply to RCPT TO command))


    CONFIG_TEXT: postfix / smtp [21756]: 6EB2880CAD5E: to = <john.doe@example.com>, relay = mx1.example.com [203.0.113.2]: 25, delay = 0.64, delays = 0.05 / 0.01 / 0.15 / 0.43, dsn = 5.0.0, status = bounced (host mx1.example.com [203.0.113.2] said: 550 Rejecting for Sender Policy Framework (in reply to RCPT TO command))

  • Similar issue may occur with other public mail services, like Hotmail etc.

  • The message can be also placed to the spam folder.

Cause

SPF record is not set properly.

Resolution

Using Plesk Interface

  1. Log in to Plesk.

  2. Go to Domains > example.com > DNS Settings.

  3. Check the syntax of SPF record according to the article How to check whether a domain has a correctly set SPF record?

    If a domain does not have an SPF record, add it by clicking Add Record, selecting TXT Record Type:

    v=spf1 +a +mx -all:

Using SSH/RDP connection

Connect to the server via SSH/RDP and execute the following command in the Command Prompt or Linux Shell:

on Windows :

C:\> plesk bin dns --add example.com -txt "v=spf1 +a +mx -all"

on Linux :

# plesk bin dns --add example.com -txt "v=spf1 +a +mx -all"

Note: if SPF record was updated recently wait till proper SPF record will be propagated 12-24h

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.