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Unable to open the "Updates and Upgrades" page or start Plesk Installer in CLI: Update operation was locked by another update process

Plesk for Windows Plesk for Linux kb: technical ABT: Group A FR:PPM-2446

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • When clicking on Updates and Upgrades in Plesk, the page prompts for a root password or does not open at all with one of the following error messages in a web-browser:

    The connection has timed out


    This site can’t be reached


    ERR_TIMED_OUT

  • When starting Plesk Installer in a command-line interface, the following message is shown:

    BUSY: Update operation was locked by another update process.


    Error: Unable to start Plesk Installer. The following error has occurred: Installation could not be started: another installation procedure is currently running.

Cause

A Plesk Installer process is running on the server already, but only one Plesk Installer process can be launched at a time.

Resolution

Terminate active Plesk Installer processes:

Note: Before applying the solution below, make sure that other users on the Plesk server are not using Plesk Installer.

  1. Connect to the Plesk server via SSH (Linux) / RDP (Windows Server)

  2. Stop Plesk Installer processes (on Windows Server, use a command prompt as Administrator):

    # plesk installer stop

For Plesk Onyx, apply the following steps:

For Plesk on Linux
  1. Connect to the Plesk server via SSH

  2. Find the PIDs of Plesk Installer processes:

    # ps aux | grep install | grep -v grep

    root 12345 1.5 0.8 136856 18280 ? S 20:43 0:00 /var/cache/parallels_installer/parallels_installer_CentOS_7_x86_64_3.21.3 --service-mode --enable-xml-output --ssl-cert /usr/local/psa/admin/conf/httpsd.pem --branch release,stable --web-interface --with-ssl --disable-browser
    root 12346 0.0 0.1 109776 2808 ? S 20:43 0:00 /var/cache/parallels_installer/parallels_installer_CentOS_7_x86_64_3.21.3 --service-mode --enable-xml-output --ssl-cert /usr/local/psa/admin/conf/httpsd.pem --branch release,stable --web-interface --with-ssl --disable-browser

  3. Kill found processes using the command below. Replace 12345 12346 with actual PIDs from the step above:

    # kill -9 12345 12346

  4. Remove the /tmp/psa-installer.lock file, if it exists

  5. Start Plesk Installer

For Plesk on Windows Server

Apply one of the following solutions:

  • Terminate Plesk Installer processes using a command prompt:

    1. Connect to the Plesk server via RDP

    2. Start a command prompt

    3. Find the PID of a Plesk Installer process:

      wmic process where "caption like '%installer%'" get processId,caption
      Caption ProcessId
      parallels_installer_Microsoft_10.0_x86_64_3.22.12.exe **6444
      **Caption ProcessIdai.exe 6444

    4. Kill the process using its PID:

      taskkill /PID 6444 /F

    5. Kill the ai.exe process:

      taskkill /FI "IMAGENAME eq ai.exe" /F

  • Terminate Plesk Installer processes using Windows Task Manager

    1. Open Task Manager (Open Windows Start > type "Task Manager")

    2. Right-click on each existing "Plesk Installer" process and click End Task:

      Note: Plesk Installer processes can have one of the following names depending on Plesk version: Plesk Installer, ai.exe, parallels-installer.exe or plesk-installer.exe.

      End Plesk Installer tasks with Windows Task Manager

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Comments

1 comment
Date Votes
  • It seems that if you have (and forgot) a Firewall rule allowing the Plesk Installer to be only accessed from specific IPs the connection will also timed out but it will somehow trigger the Plesk Installer to become locked. The Plesk Installer on CLI then says “Update operation was locked by another update process.” if you try to load the Plesk Installer on CLI e.g. by >plesk installer list. Stop the plesk installer on CLI using the stop command, add you IP, apply the Firewall rule and load the Plesk Installer again now it will load.

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