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Mails are not delivered to a local mailbox of a domain in Plesk

Plesk for Windows Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Incoming emails (from @gmail) sent to a Plesk domain (@example.com) are being returned
  • Outgoing e-mails are delivered fine (from Plesk server to other servers)
  • Mail service is enabled for the domain
  • MX record is resolved to another server globally:

    # dig mx example.com +short @8.8.8.8
    10 mail.example.com.
    # dig mail.example.com +short
    203.0.112.2

    or does not resolve at all:

    # dig mx example.com +short @8.8.8.8
    #

    # dig mail.example.com +short @8.8.8.8
    #

Cause

The MX record in the DNS zone of example.com is not set correctly.

Resolution

Click on a section to expand

If the DNS zone of example.com is managed in Plesk:
  1. Log in to Plesk.
  2. Domains > example.com > DNS Settings

    Make sure that configured MX record is resolved to the correct IP address and mail server. Contact your domain registrar for assistance.

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If the DNS zone of example.com is not managed in Plesk.

Contact the domain name administrator or the domain registrar to perform such change in the DNS zone.

Note: In any case, DNS propagation to Internet may take from 24 to 48 hours.

Additional Information

Adding and Modifying DNS Records

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Comments

1 comment
Date Votes
  • Mx record resolve to the correct IP address and mail server

    but mails from gmail and other external mail cant be delivered to my mail hosted on plesk

    0

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