Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
example.com is hosted locally in Plesk, but its mail is handled by an external mail server.
-
When sending an email from one of the domains hosted in Plesk to a mailbox of example.com, the email fails to be delivered with one of the following error messages in
/usr/local/psa/var/log/maillog
:CONFIG_TEXT: 550 5.1.1 jdoe@example.com: Recipient address rejected: User unknown in virtual mailbox table; from=test@pleskdomain2.com to=jdoe@example.com
CONFIG_TEXT: example.com postfix-local[23040]: cannot chdir to mailname dir contact: No such file or directory
example.com postfix-local[23040]: Unknown user: jdoe@example.com
CONFIG_TEXT: ME-E0103: [1076] Local Delivery: Failure - Domain for ([SMTP:jdoe@example.com]) is locally serviced, but recipient is not defined in address map.
-
In webmail, the following error message is shown:
CONFIG_TEXT: Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid
Error: SMTP Server rejected email. Returned:550 sorry, no mailbox here by that name. (#5.7.17)
CONFIG_TEXT: Error SMTP (500): The following recipient could not be reached "jdoe@example.com" (sorry, no mailbox here by that name. (#5.7.17)).
CONFIG_TEXT: There was an error sending your message: Message could not be delivered - the address was not found, is unknown, or is not receiving messages.
CONFIG_TEXT: 550 5.1.1 jdoe@example.com ... User unknown (in reply to MAIL FROM command))
Cause
When mail service of a domain is enabled in Plesk, local mail server treats this domain as a local domain and tries to send emails locally.
Resolution
-
Go to Domains > example.com > Mail tab > Mail Settings.
-
Switch Mail service on this domain to Disabled for incoming mail.
-
Apply the changes.
Comments
0 comments
Please sign in to leave a comment.