Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
Plesk installation/update/upgrade/repair fails with one of the following errors:
CONFIG_TEXT: File downloading products.inf3: Error: Couldn't resolve host 'autoinstall.plesk.com', retry...
Error: Couldn't resolve host 'autoinstall.plesk.com', retry...
CONFIG_TEXT: Syntax error in file /root/parallels/PHP73_17/php73-ubt20.04-x86_64.inf3: Error reading end tag.
CONFIG_TEXT: Error: Failed to read product information from the file : Can't process products.inf3: Failed to download the file http://autoinstall.plesk.com/products.inf3:
Could not resolve host: autoinstall.plesk.com
Cause
The address autoinstall.plesk.com
(on Plesk for Linux) or autoinstall-win.plesk.com
(on Plesk for Windows servers) is not resolvable from a Plesk server due to network issues.
Resolution
-
Since the issue may be a temporary one, retry to update/upgrade Plesk later after some time.
-
If the issue still persists, perform the checks below and contact your hosting/ISP provider with the collected information for further troubleshooting of the network-related issue:
-
Connect to a Plesk server via SSH.
-
Check if
autoinstall.plesk.com
is accessible from the server using theping
andnslookup
utility:# ping autoinstall.plesk.com
# nslookup autoinstall.plesk.com
-
Verify that a firewall is not blocking the connection.
-
Make sure nameservers in the
/etc/resolv.conf
file are valid. In case of any doubts, use Google Public DNS IP addresses as shown below:# cat /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4 -
Check that there is no
search
record in the/etc/resolv.conf
file. If thesearch
record is present, it prevents the DHCP client from updating the file/etc/resolv.conf
(if it is updated automatically). Either comment out thesearch
directive or add the link to the hostautoinstall.plesk.com
as shown below:# cat /etc/resolv.conf
; generated by /sbin/dhclient-script
search example.com autoinstall.plesk.com
nameserver 192.0.2.2
-
Connect to the Plesk server via RDP.
-
Start a command prompt and check if
autoinstall-win.plesk.com
is accessible from the server using theping
andnslookup
utilities:C:\> ping autoinstall-win.plesk.com
C:\> nslookup autoinstall-win.plesk.com
-
Verify that a firewall is not blocking the connection to
autoinstall-win.plesk.com
.
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