Applicable to:
- Plesk for Windows
Symptoms
-
Unable to create a database dump in Plesk > Domains > example.com > Databases > Export Dump:
mysqldump: Got error: 1045: Access denied for user 'admin'@'localhost' (using password: YES) when trying to connect
-
Attempts to manage MySQL/MariaDB databases or remove mailbox produces errors:
Error: Connection to the database server has failed because of network problems: Try to establish connection failed
Error: Connection to the database server has failed because the supplied account does not possess administrative privileges: Access denied for user 'admin'@'localhost' (using password: YES)
-
The MySQL/MariaDB server is marked red on the Tools & Settings > Database Servers screen.
Cause
Plesk stores an incorrect MySQL/MariaDB server administrator password.
Resolution
Reconnect Plesk to the MySQL/MariaDB server:
-
Connect to the server using RDP
-
Edit the MySQL/MariaDB configuration file
%plesk_dir%Databases\MySQL\my.ini
and add the lineskip-grant-tables
to the[mysqld]
section and save it using text editor:[mysqld]
skip-grant-tables -
Restart the MySQL/MariaDB server (but not "Plesk SQL Server"), running on port 3306 using the Plesk Services Monitor, which can be started from the Windows Start menu.
Note: Plesk Services Monitor could also be started using the next cmd.exe command:
C:\> "%plesk_dir%\admin\bin\traymonitor.exe"
-
Log into MySQL/MariaDB without the password:
"%plesk_dir%\MySQL\bin\mysql.exe" -P3306
-
Reload the grant-tables policies by running the next command:
FLUSH PRIVILEGES;
- Update/recreate the user by specifying a new password using the next command:
C:\> grant all privileges on *.* to 'admin'@'localhost' identified by 'new_password' with grant option;
Note: Make sure to replace 'new_password' with a new password of choice:
-
Tell the database server to reload the grant tables by issuing the FLUSH PRIVILEGES command;
FLUSH PRIVILEGES;
-
Remove the
skip-grant-tables
from the MySQL/MariaDB configuration file(%plesk_dir%Databases\MySQL\my.ini
) and restart the service again as in Step 3. -
Log in to the Plesk interface, go to the database server management settings ( Tools & Settings > Database Servers ) and open the server's settings:
-
On the opened page click the "Settings" button and specify new the password that was set in Step 6:
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