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Some Plesk operation failed: no secure shell available

Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • An attempt to perform one of the following operations in Plesk might fail:

    • Creating a Subscription

    • Changing the password of the main Subscription system user in example.com > Web Hosting Access

    • Deploying an application (e.g., WordPress)

    • Settings Permanent SEO-safe 301 redirect from HTTP to HTTPS at Plesk > Domains > example.com > Hosting settings

    The operations might fail with the following error:

    PLESK_ERROR: Error: no secure shell available

  • Plesk detects all the shells correctly:

    # plesk sbin sysinfo getshell
    /bin/false
    /bin/sh
    /bin/bash
    /usr/bin/sh
    /usr/bin/bash
    /usr/local/psa/bin/chrootsh /bin/bash (chrooted)

Cause

The pre-defined shell set in the file /usr/local/psa/admin/conf/site_isolation_settings.ini overrides the settings configured at the Service Plan level:

# egrep "shell.*=" /usr/local/psa/admin/conf/site_isolation_settings.ini
shell = /bin/bash

Resolution

Note: The solution described in this article needs to be applied by the Plesk server administrator via SSH. If server access is not possible, please contact the service provider.

  1. Connect to the server via SSH

  2. Back up the configuration file /usr/local/psa/admin/conf/site_isolation_settings.ini:

    # cp -a /usr/local/psa/admin/conf/site_isolation_settings.ini{,.backup}

  3. Comment out the forced shell parameter from the configuration file /usr/local/psa/admin/conf/site_isolation_settings.ini:

    # sed -i.bak 's/shell.*=/;shell =/g' /usr/local/psa/admin/conf/site_isolation_settings.ini

  4. Control the SSH access permissions in the corresponding Service Plan or per-subscription:

    • Service Plan: Log in to Plesk GUI > Service Plans > Service Plan Name > Permissions > Management of access to the server over SSH > Can allow access only to a chrooted environment or Can allow access to any type of shell > Update & Sync

    • Subscription: Log in to Plesk GUI > Subscriptions > example.com > Customize (Right-sidebar) > Permissions > Management of access to the server over SSH > Can allow access only to a chrooted environment or Can allow access to any type of shell > Update & Lock

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  5. In case the issue persists, enable the Setup of potentially insecure web scripting options that override provider's policy option in the corresponding Service Plan or per-subscription:

    • Service Plan: Log in to Plesk GUI > Service Plans > Service Plan Name > Permissions > Enable Setup of potentially insecure web scripting options that override provider's policy option > Update & Sync

    • Subscription: Log in to Plesk GUI > Subscriptions > example.com > Customize (Right-sidebar) > Permissions > Enable Setup of potentially insecure web scripting options that override provider's policy option > Update & Lock

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Comments

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  • I've tried this steps but I still keep on getting the Error: no secure shell available. Is there any other way to solve this. I am trying to install the SSL cert to a domain.

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