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Outgoing mail shows in mail headers: Domain of transitioning does not designate as permitted sender

Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • One of the following entries are shown in the headers of the outgoing mail:

    CONFIG_TEXT: Received-SPF: softfail (google.com: domain of transitioning mail@example.com does not designate 203.0.113.2 as permitted sender) client-ip=203.0.113.2;

    OR

    CONFIG_TEXT: Received-SPF: fail (servername.example.com: domain of example.com does not designate 203.0.113.2 as permitted sender) client-ip=203.0.113.2;

    OR

    CONFIG_TEXT: Received-SPF: neutral (google.com: 203.0.113.2 is neither permitted nor denied by best guess record for domain of jdoe@example.com) client-ip=203.0.113.2;

  • 203.0.113.2 is an IP of the server or a trusted IP.

Cause

There is no SPF record for example.com, or the SPF record is misconfigured: it has incorrect format or an IP is not listed in SPF record for example.com.

Resolution

Note: if DNS is managed by a 3rd party DNS server, the record should be configured there.

  1. Go to Domains > example.com > DNS Settings.

  2. Add Record/update an existing TXT record and add the IP (in our case 203.0.113.2) as a permitted sender:

    2018-05-10_02_26_23-The_Plesk_s_DNS_server_acts_as_a_primary_name_server_for_the_DNS_zone_example.co.png

    The record will look like this:

    CONFIG_TEXT: TXT example.com "v=spf1 ip4:203.0.113.2 ~all"

    2018-05-10_02_44_52-Add_a_Resource_Record_to_the_Zone_-_Plesk_Onyx_17.8.11.png

  3. To apply changes to the DNS zone press Update button.

Additional information

Refer to the following article to verify SPF record for the domain:

  • 213901545 How to check whether a domain has a correctly set SPF record?
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