Applicable to:
- Plesk for Linux
Symptoms
-
After sending message to mail box
john_doe@alias.comthe following warning is shown in webmail:Roundcube:
CONFIG_TEXT: An error occurred while saving sent message. Unable to perform operation. No free disk space.
Horde:
CONFIG_TEXT: You exceeded mail quota
Note: The same can be true for mail forwarding.
-
The mailbox quota is set to Unlimited or its limit is not reached at Plesk > Domains > example.com > Email Addresses.
-
Subscription disk space is set to unlimited or its limit is not reached, which can be seen at Plesk > Domains > example.com > View More Statistic.
-
Unable to synchronize a mailbox with a mail client or send an email to john_doe@example.com. The following error appears in
/var/log/maillogfile:CONFIG_TEXT: postfix/pipe[17519]: 7AEB011C1531: to=<john_doe@example.com>, relay=plesk_virtual, delay=25950, delays=25950/0/0/0.12, dsn=4.3.0, status=deferred (temporary failure. Command output: Mail handler 'check-quota' said: REPLY:452:4.2.2 Mailbox full 4.2.1 Message can not be delivered at this time )
CONFIG_TEXT: postfix/cleanup[16783]: B22C11DC00BE: milter-reject: END-OF-MESSAGE from smtp.gmail.com[127.0.0.1]: 4.2.2 Mailbox full; from=user@gmail.com to=<john_doe@example.com> proto=ESMTP helo=<smtp.gmail.com>
Cause
The file /var/qmail/mailnames/example.com/john_doe/Maildir/maildirsize is corrupted.
Resolution
-
Connect to the server via SSH.
Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.
-
Remove the file
maildirsizeof the affected domain:# rm -rf /var/qmail/mailnames/example.com/john_doe/Maildir/maildirsize
-
example.com - a name of an affected domain
-
john_doe - a name of an affected mailbox
-
-
Recreate the file
maildirsizeby re-saving the same settings defined in Plesk:
-
Go to Domains > example.com > Email Addresses > john_doe@example.com > click OK without making any changes
Comments
We really need a better way to resolve this. For example an automated way to determine which maildirsize files are corrupted.
Should we sechedule a run of "plesk repair mail' every week?
Yes, indeed! By the way, this problem also appears if you move a domain to a different subscription. I just reorganised my subscription managing system and thus had to repair about 20 mailboxes like this…
plesk repair mail does not solve this issue
Just experienced the same thing! from moving a domain to a different subscription. It seems you either have to check immediately after moving the domain or wait for the client to complain they aren't receiving emails!
Very sketchy.
More data:
Background / Known Issue
Mailboxes showing
452 4.2.2 Mailbox fulleven when quota is unlimited or well under limits, triggered by a corruptedmaildirsizefile Plesk Support+1.Why it matters
rmthose files to restore correct mailbox behavior.Suggested Improvement
maildirsize(and potentially other Dovecot index/quota files) whenever mailboxes are moved, subscription limits change, or mail plans are updated.Hello FutureX
We have reproduced this behavior in our test environment and submitted a bug with ID PPPM-15068.
Thank you for providing the feedback.
Please sign in to leave a comment.