Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
The Plesk Panel, a website, or webmail can't be reached and returns a browser error
Unable to connect
Your Internet access is blocked ERR_NETWORK_ACCESS_DENIED
This site can’t be reached
example.com took too long to respond
ERR_CONNECTION_TIMED_OUT
The connection has timed out
ERR_SSL_VERSION_OR_CIPHER_MISMATCH
-
MXToolBox TCP Port Status tool and
nmap
say that ports 80/443 are filtered# nmap 203.0.113.2 -p 80,443
PORT STATE SERVICE
80/tcp filtered http
443/tcp filtered https -
The domain resolves to the right Plesk Server IP address
# dig +short example.com
203.0.113.2 -
cURL requests from inside the server work
# curl -I http://example.com/
HTTP/1.1 200 OK# curl -I http://example.com/
HTTP/1.1 301 Moved Permanently -
cURL requests from outside the network fail
# curl -I http://example.com
curl: (7) Failed connect to example.com:80; Connection timed out
Cause
Ports 80 or/and 443 are blocked by a firewall.
Resolution
Open the web ports 80 and 443 on the firewall.
Note: If the issue persists, contact the ISP, hosting provider, or network administrator for assistance locating and opening the block.
- To automatically configure the internal firewall to allow all necessary connections, use Plesk Firewall. Additional software (like Imunify360) must also be configured according to its documentation.
- For external firewalls, follow the appropriate guide (contact the hosting provider if not listed): Amazon EC2, Lightsail, Google Cloud, Azure, Alibaba Cloud.
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