Applicable to:
- Plesk for Linux
Symptoms
-
Domain example.com does not work:
PLESK_INFO: 503 service unavailable
PLESK_INFO: 502 Bad Gateway
Nginx -
The following error appears in domain's error log
/var/www/vhosts/system/example.com/logs/error_log
:CONFIG_TEXT: [proxy:error] [pid 15065:tid 139826443527936] (111)Connection refused: AH02454: FCGI: attempt to connect to Unix domain socket /data/vhosts/system/example.com/php-fpm.sock (*) failed
[proxy_fcgi:error] [pid 15065:tid 139826443527936] [client 203.0.113.2:50232] AH01079: failed to make connection to backend: httpd-UDS
Cause
Configuration file for a domain is missing in /opt/plesk/php/X.X/etc/php-fpm.d/
directory.
Resolution
Regenerate the configuration:
- Log into Plesk.
- Go to Domains > example.com > PHP Settings and change PHP handler to different one and click OK
- Change PHP handler version back and click OK.
If multiple domains are affected:
-
Connect to the server via SSH;
Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.
-
Execute the following command to update settings on all domains:
# /usr/local/psa/bin/php_settings -u
-
Restart PHP handler processes, for example:
# systemctl restart plesk-php74-fpm
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