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Cannot set up Plesk mail IMAP account in Outlook: SASL DIGEST-MD5 authentication failed: authentication failure

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • When trying to set up an IMAP account in Outlook, Samsung Email android app (or another similar email client application) the IMAP option is not available in the "Account type" field:

    IMAP.png

  • One of the following errors can be found in the /var/log/maillog of the server:

    CONFIG_TEXT: server dovecot: imap-login: Disconnected: Inactivity during authentication (client didn't finish SASL auth, waited 179 secs): user=<>, method=DIGEST-MD5, rip=127.0.0.1, lip=127.0.0.1, TLS, session=<Uzcj+sRVW+J/AAAB></>

    CONFIG_TEXT: SASL DIGEST-MD5 authentication failed: authentication failure

  • The cannot be reproduced with all email clients and clients such as Thunderbird are working just fine

Cause

Current implementation of a DIGEST-MD5 authentication in libsasl2-2 package is incompatible with Microsoft Outlook and some other mail clients. Additional details can be found here.

Resolution

Note: if you don't have root access to Plesk server via SSH, contact your hosting provider regarding the issue

  1. Login to Plesk server over SSH

  2. Create a custom configuration file /etc/dovecot/conf.d/00-auth_mechs.conf and place the auth_mechanisms parameter without digest-md5 within it, for example:

    # vi /etc/dovecot/conf.d/00-auth_mechs.conf

    CONFIG_TEXT: auth_mechanisms = plain login cram-md5 apop

  3. Restart Dovecot to apply the configuration changes:

    # service dovecot restart

Additional information

Outlook fails to send an email: SASL authentication failure

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  • auth_mechanisms = plain login scram-sha256
    ?

    0

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