Articles in this section

Unable to start migration: Unable to execute command because another migration is in progress

Plesk for Windows kb: technical ext: migrator ABT: Group A

Applicable to:

  • Plesk for Windows

Symptoms

  • Unable to start a migration at Tools & Setting > Migration and Transfer Manager. The following message is shown in Plesk Migrator UI:

    PLESK_ERROR: Unable to execute command because another migration is in progress

  • The "Starting a migration" step is hung.

Cause

Possible causes:

  • Another migration process is running.

  • Plesk Migrator processes are stuck.

  • Temporary files left after previous processes. Temporary files can be present if the process was crashed or "killed" by a user and thus a cleaning up was not performed properly.

Resolution

If there is another running migration session:
  1. Log into Plesk

  2. Go to Tools & Setting > Migration and Transfer Manager

  3. Stop all running migrations or wait for the current subscriptions migration to finish

  4. Re-run new migration session

If there are no currently running migration sessions:
  1. Log into Plesk

  2. Go to Tools & Setting > Migration and Transfer Manager

  3. Stop all running migrations and remove all sessions by clicking the Finish migration button

  4. Connect to the target server via RDP

  5. Remove or move out orphaned directories from previous migration sessions:
    4.1. Open File Explorer and navigate to the directory %plesk_dir%var\modules\panel-migrator\sessions
    4.2. If there are any directories inside the directory sessions remove or move out them

  6. Kill all possibly hanging processes:

    C:\> taskkill /T /F /IM python.exe /IM rsync /IM paexec.exe /IM MailMigrator.exe /IM pmmcli.exe

  7. Open Plesk > Tools & Setting > Migration and Transfer Manager and start a new mitigation.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.