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Apache settings are not applied immediately in Plesk

Plesk for Linux kb: technical ABT: Group B Ideal

Applicable to:

  • Plesk for Linux

Symptoms

  • An SSL certificate assigned to a domain in Plesk at Domains > example.com > Hosting & DNS > Hosting is not used by the website.
  • An SSL certificate assigned at Domains > example.com > SSL/TLS Certificates > Secure Webmail is not used by the webmail.
  • After suspending/disabling a subscription or a domain, the website is still accessible.
  • After enabling/activating a subscription or a domain, the website still shows a 503 Temporary Unavailable error.
  • When changing the PHP version in Plesk at Domains > example.com > PHP Settings, the following warning is shown:

    PLESK_WARN: You have changed the PHP handler settings. If you save these changes, PHP scripts on your website may stop for 1800 seconds because of your server configuration.

Cause

Apache restart interval, set up at Tools & Settings > Apache Web Server, delays Apache restart, so the changes are not applied immediately.

Resolution

Note: If Apache graceful restart is enabled on the server, it is recommended to keep Apache restart interval value at 0.

Apply one of the following solutions:

Restart Apache service manually
  1. Log in to Plesk.
  2. Go to Tools & Settings > Services Management.
  3. Click button next to Web Server (Apache).
Disable or reduce the Apache restart interval
  1. Log in to Plesk.
  2. Go to Tools & Settings > Apache Web Server.
  3. Set Apache restart interval to a lower value or set the value to 0 to disable the setting.
  4. Apply the changes.
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Comments

1 comment
Date Votes
  • Subject: SSL Certificate Not Working for Webmail

    Description:

    Hello,

    I am experiencing an issue with the SSL certificate for my domain. The SSL certificate assigned to the domain fastcons.com is working correctly for the website, but it is not being applied to the webmail service.

    Here are the details:

    • Domain: fastcons.com
    • Local IP Address: 10.0.51.5
    • External IP Address: 178.238.123.78

    Steps Taken:

    1. I have attempted to manually reconfigure the domain using the following command:
      bash
      plesk sbin httpdmng --reconfigure-domain fastcons.com
    2. I restarted the web server services using the following commands:
      • Apache service:
        bash
        plesk sbin websrvmng --restart
      • NGINX service:
        bash
        plesk sbin nginx_control --restart

    Despite these efforts, the SSL certificate is still not applied to the webmail service.

    Request:

    I kindly request your assistance in resolving this issue. Could you please investigate and provide guidance on how to ensure that the SSL certificate is properly applied to the webmail service?

    Thank you for your support.

    Best regards, Erdil ÖZTÜRK

    0

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