Plesk for Linux
kb: technical
ABT: Group B
Ideal
Applicable to:
- Plesk for Linux
Symptoms
-
A newly assigned SSL certificate at Domains > example.com > Hosting & DNS > Hosting is not used by the website.
-
An SSL certificate assigned at Domains > example.com > SSL/TLS Certificates > Secure Webmail is not used by the webmail.
- A subscription or domain continues to work after it has been suspended/disabled.
Cause
Apache graceful restart, set up at Tools & Settings > Apache Web Server, delays Apache restart, so the changes are not applied immediately.
Resolution
Apply one of the following solutions:
Restart Apache service manually
-
Go to Tools & Settings > Services Management.
-
Click button next to Web Server (Apache).
Disable or reduce the Apache restart interval
-
Go to Tools & Settings > Apache web server > Set Apache restart interval to a lower value or set the value to 0 to disable the setting.
Comments
1 comment
Subject: SSL Certificate Not Working for Webmail
Description:
Hello,
I am experiencing an issue with the SSL certificate for my domain. The SSL certificate assigned to the domain
fastcons.com
is working correctly for the website, but it is not being applied to the webmail service.Here are the details:
Steps Taken:
plesk sbin httpdmng --reconfigure-domain fastcons.com
plesk sbin websrvmng --restart
plesk sbin nginx_control --restart
Despite these efforts, the SSL certificate is still not applied to the webmail service.
Request:
I kindly request your assistance in resolving this issue. Could you please investigate and provide guidance on how to ensure that the SSL certificate is properly applied to the webmail service?
Thank you for your support.
Best regards, Erdil ÖZTÜRK
Please sign in to leave a comment.