Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Website hosted in Plesk is inaccessible or an operation on a website fails:
CONFIG_TEXT: 500 Internal Server Error
CONFIG_TEXT: 504 Gateway Timeout
-
The following error may occur when the WordPress domain is not accessible:
CONFIG_TEXT: There has been a critical error on your website.
Learn more about debugging in WordPress. -
PHP errors that are similar to the following are generated in the website's PHP error logs:
Note:
Logs location on a Linux server:/var/www/vhosts/system/example.com/logs/error_log
Logs location on a Windows server:%plesk_vhosts%\example.com\logs\php_errors\example.com\php_error.log
Error example for Linux:
CONFIG_TEXT: AH01071: Got error 'PHP message: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 28672 bytes) in /var/www/vhosts/example.com/httpdocs/moodle/lib/filestorage/stored_file.php on line 1143', referer: https://example.com/user/index.php?id=10
Error example for Windows:
CONFIG_TEXT: PHP Fatal error: Allowed memory size of XXX bytes exhausted (tried to allocate XXX bytes) in C:\Inetpub\vhosts\example.com\httpdocs\wp-config.php on line 91
Cause
The website reaches the PHP memory limit and thus generates web servers errors which make it unavailable or processed very slowly by the web server.
Resolution
-
Go to Domains > example.com > PHP Settings and increase
memory_limit
value according to the application requirements, by using the instructions from the following article:
How to change PHP memory_limit value via Plesk?Note: the following shortcuts should be used for
memory_limit
value: K (kilobytes), M (megabytes), and G (gigabytes). If the "free -mh" command shows not enough RAM, contact your Cloud hosting provider to increase it
Comments
0 comments
Please sign in to leave a comment.