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A website hosted in Plesk shows wrong website content when opened over HTTPS after migration from a legacy Plesk version

Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux

Symptoms

  • A website has been migrated to Plesk from a legacy Plesk version.

  • When opening this website in a web-browser, it loads the real content over HTTP, but different over HTTPS. For HTTPS, it also can be a Plesk default page or Apache test page.

  • Opening other pages of the website over HTTPS result in "404 Not Found" or "403 Forbidden".

Cause

The domain is running in "Separate SSL/TLS and non-SSL/TLS content" compatibility mode.

Domains in Plesk 11 and earlier releases had their content stored in separate directories for HTTP and HTTPS:

  • /var/www/vhosts/example.com/httpdocs - for HTTP content
  • /var/www/vhosts/example.com/httpsdocs - for HTTPS content

Resolution

  1. Connect to the Plesk server via SSH.

  2. Disable the compatibility mode in the Plesk database:

    # plesk db "UPDATE hosting set same_ssl='true' WHERE same_ssl='false';"

  3. Repair web-server configuration:

    # plesk repair web -y

 

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Date Votes
  • This option is not available anymore in newer Plesk versions. How can I still resolve this for a customer on a server?

    1

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