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A Plesk backup task completes with the warning: This system user has no read access to

Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux

Symptoms

  • A Plesk backup task completes with one of these warnings:

    PLESK_INFO: Warning: (domain object 'example.com')
    Not all the data was backed up into /var/lib/psa/dumps/clients/jdoe/domains/example.com successfully.
    Total space: 714.00 GB; Available space: 508.00 GB; Mounted on: /var.
    For security reasons, backing up is performed on behalf of subscription's system user. This system user has no read access to:
    /var/qmail/mailnames/example.com/jdoe/Maildir/subscriptions
    So it was not backed up. All other data was backed up successfully. To fix this issue you may run the command 'plesk repair fs' or grant access read/write manually to the file or directory for system user "popuser" or "apache".


    PLESK_INFO: This system user has no read access to:
    /var/www/vhosts/example.com/modules/export_catalog/datas/export_catalog123abc
    /var/www/vhosts/example.com/modules/export_catalog/datas/export_catalog456def
    So it was not backed up. All other data was backed up successfully. To fix this issue you may grant access read/write to the file or directory for system user "username" or "apache".

  • The plesk repair fs command does not show any errors:

    # plesk repair fs example.com
    Checking virtual hosts' file system ................................. [OK]

    Error messages: 0; Warnings: 0; Errors resolved: 0

Cause

The files mentioned in the warning have incorrect permissions.

Resolution

Use one of the following solutions

 

Solution I: Fix permissions

 

Grant read access to the files/directories for the system user mentioned in the warning message:

 

  • If files/directories inside subscription directory are affected

    1. Connect to the Plesk server over SSH.

    2. Find system user of the domain in question:

      # plesk bin subscription -i example.com | grep "FTP Login"
      john_doe

    3. Modify ownership:

      # chown -R john_doe:psacln /var/www/vhosts/example.com/<path_to_the_file_from_error>

    4. Set permissions:

      # find /var/www/vhosts/example.com/<path_to_dir_from_error> -type f -exec chmod 0644 {} \;
      # find /var/www/vhosts/example.com/<path_to_dir_from_error> -type d -exec chmod 0755 {} \;

       

  • If mail is affected

    1. Connect to the Plesk server over SSH.

    2. Set the permissions of the affected directory to the correct one (see the error message - here the required user and group is popuser):

      # chown popuser:popuser /var/qmail/mailnames/example.com/mailbox/Maildir/subscriptions

 

Solution II: exclude subscription files from Plesk backups

 

If the subscription files are not needed in the backup, ignore the warning or configure Backup Manager to exclude the files from backup.

  1. In Plesk, go to Domains > example.com > Backup Manager and enable the option Exclude specific files from the backup.

    Note: Excluding directory from server-wide backup at Tools & Settings > Backup manager, will exclude it from all domains on a server. We recommend to exclude directories for each domain separately.

  2. Specify the path or paths relative to the web space root, separating individual files with commas. Using the mask symbol is allowed.


    Screenshot_2019-01-15_Scheduled_Backup_Settings_-_Plesk_Onyx_17_8_11.png

 

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