Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to send an email from a Plesk server, the delivery fails with one of the following error messages:
CONFIG_TEXT: 554-example.com (hostname) ESMTP Service not available
554-No SMTP service
554 invalid DNS PTR resource record, IP=203.0.113.2CONFIG_TEXT: 554-Bad DNS PTR resource record.
Click here to expandCONFIG_TEXT: 21 Temporarily rejected. Reverse DNS for this IP failed. IB108 The IP address attempting to send mail does not have reverse DNS setup, or the DNS lookup failed. Verify the sending IP address has reverse DNS setup before resending the email.
CONFIG_TEXT: 550-5.7.1 [203.0.113.2] The IP address sending this message does not have a PTR
CONFIG_TEXT: (host example.info[203.0.113.111] refused to talk to me: Service not available - no PTR record for 203.0.113.2)
CONFIG_TEXT: 550 No rDNS entry for
CONFIG_TEXT: status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:400c:c0b::1b] said: 550-5.7.1 [2001:db8:f61:a1ff:0:0:0:80] Our system has detected that this message does 550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and 550-5.7.1 authentication. Please review 550-5.7.1 https://support.google.com/mail/?p=IPv6AuthError for more information
CONFIG_TEXT: X-Host-Lookup-Failed: Reverse DNS lookup failed for 203.0.113.2
CONFIG_TEXT: 4.0.0 deferred (host mx01.emig.gmx.net[203.0.113.2] refused to talk to me: 554-gmx.net (mxgmx109) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit https://postmaster.gmx.net/en/case?c=r0601&i=ip&v=203.0.113.2&r=1M750R-1tW80L1jd1-006Fgn)
-
There is no DNS PTR record for the sending server's IP address:
# dig @8.8.8.8 +short example.com
203.0.113.2
# dig -x 203.0.113.2 +short
(Empty output or it resolves to a domain that doesn't resolve to the sender's IP address)Note: Where
example.com
is a domain hosted on a Plesk server and203.0.113.2
is the Plesk IP address assigned to the domain tied to the mailbox that is sending the email in Plesk
Cause
The email message is rejected due to security policy on the side of the recipient mail server.
The mentioned policy prevents email that is incoming from a server IP that either does not have a PTR record or has one that is considered default for server providers such as 123-123-123-123-static.yourprovider.tld
.
Resolution
Note: DNS propagation usually takes up to 8 hours, however in rare cases in may last for up to 48 hours.
Contact your server provider (or Internet Service Provider) in order to receive assistance in adding the appropriate PTR records to the IP addresses that are assigned to your server by your server provider.
The following PTR value structure is an example that is recommended for use:
server.yourdomain.tld
The PTR record that you use for the server IP must match the hostname that you have specified in Plesk
In case of Plesk is installed on Cloud infrastructure, you may find additional instructions in the following article:
How to add PTR record to Cloud Server with installed Plesk?
Additional information
What value should be used in the PTR (rDNS) record for an IP address that is used on a Plesk server?
How to specify the hostname used by MailEnable for sending outbound mail
Comments
0 comments
Please sign in to leave a comment.