Articles in this section

Unable to send emails to certain recipients in Plesk : 25: Connection timed out

Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Unable to send email from the server to certain recipients.

  • The following can be found in /var/log/maillog:

    CONFIG_TEXT: main postfix/smtp[16855]: connect to mx.example.com:25: Connection timed out
    main postfix/smtp[16855]: BE46D121BD6: to=jdoe@example.com, relay=none, delay=150, delays=0.13/0.01/150/0, dsn=4.4.1, status=deferred (connect to mx.example.com:25: Connection timed out)

  • Outgoing mail mode is set to Send from the specified IP addresses and IPv4 is set to 203.0.113.2 in Tools & Settings > Mail Server Settings.

  • Emails are successfully sent if Send from domain IP addresses is enabled in Tools & Settings > Mail Server Settings or if QMail is selected in Tools & Settings > Mail Server Settings > Installed mail server.

  • In Tools & Settings > IP Addresses there is a private IP address 192.0.2.2, for which a public IP address 203.0.113.2 is assigned and there is a separate IP address 203.0.113.2.

Cause

Non-routable IP address 203.0.113.2 is being used for sending emails.

Resolution

  1. Log into Plesk

  2. Go to Tools & Settings > Mail Server Settings and switch Outgoing mail mode to internal IP address 192.0.2.2 or another IP address that is routable on this server.

Was this article helpful?

Comments

1 comment
Date Votes
  • doesn't solve my problem

    0

Please sign in to leave a comment.