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Plesk-hosted website shows wrong content

Plesk for Windows Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Website shows wrong content.
  • Domain resolves into IP address that is missing from Plesk server:

    # dig +short example.com
    203.0.113.2

    # dig +short -t AAAA example.com
    2001:0db8:85a3:0000:0000:8a2e:0370:7334

    or domain resolves into several IPs at once:

    # dig +short example.com
    203.0.113.2
    203.0.113.3

  • If Wordpress is installed for the website the following error message appear when trying to log in to WordPress admin panel:

    CONFIG_TEXT: Unknown username. Check again or try your email address.

    OR

    CONFIG_TEXT: Unknown email address. Check again or try your username

Cause

IP Address assigned to domain in Plesk doesn't match the address specified in A-record or AAAA-record on name server side.

Note: by default OS prefers IPv6 (AAAA) over IPv4 (A) address.

Resolution

  1. Log in to Plesk
  2. Go to Domains > example.com and identify IP address assigned to the domain:

    mceclip0.png

  3. Go to Domains > example.com > DNS Settings and specify the identified IP address for all DNS records

    Note: if external name server is used, the IP address should be specified there.

  4. Wait until DNS propagation is finished. It can take up to 24-48 hours. Contact registrar company in case of propagation issues.
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