Applicable to:
- Plesk for Linux
Symptoms
-
After migration DKIM verification fails to send emails to Google, Hotmail or other mail services, as a result, some emails are rejected or classified as SPAM.
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At Domains > example.com > DNS Settings: DKIM TXT record default._domainkey.example.com. looks like the following example :
PLESK_INFO: v=DKIM1; p=DKIM1; p=OlDKey..;
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New domains created contains a valid DKIM TXT record:
PLESK_INFO: v=DKIM1; p=NeWkEy..;
Cause
This is caused by Plesk bug #PPPM-6529 that will be fixed in upcoming Plesk updates.
Resolution
There are 2 workarounds:
Click on a section to expand
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Go to Domains > example.com > DNS Settings
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Click on DKIM TXT record: default._domainkey.example.com.
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Delete
p=DKIM1;
from TXT record and save changes.
As a result, record in Domains > example.com > DNS Settings will keep source DKIM key and it should look as follows:
CONFIG_TEXT: v=DKIM1; p=OlDKey..;
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Go to Domains > example.com > Mail Settings
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Disable Use DKIM spam protection system to sign outgoing email messages and save.
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Enable again Use DKIM spam protection system to sign outgoing email messages and save.
As a result, record in Domains > example.com > DNS Settings will have a new DKIM key and it should look as follows:
CONFIG_TEXT: v=DKIM1; p=NeWkEy..;
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