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After migration DKIM verification fails: dkim=fail (body hash did not verify)

kb: bug Plesk for Linux ext: migrator ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • After migration DKIM verification fails to send emails to Google, Hotmail or other mail services, as a result, some emails are rejected or classified as SPAM.

  • At Domains > example.com > DNS Settings: DKIM TXT record default._domainkey.example.com. looks like the following example :

    PLESK_INFO: v=DKIM1; p=DKIM1; p=OlDKey..;

  • New domains created contains a valid DKIM TXT record:

    PLESK_INFO: v=DKIM1; p=NeWkEy..;

Cause

This is caused by Plesk bug #PPPM-6529 that will be fixed in upcoming Plesk updates.

Resolution

There are 2 workarounds:

Click on a section to expand

Update the DKIM TXT record on the target's DNS zone for example.com to keep source DKIM TXT record
  1. Log in to Plesk

  2. Go to Domains > example.com > DNS Settings

  3. Click on DKIM TXT record: default._domainkey.example.com.

  4. Delete p=DKIM1; from TXT record and save changes.

As a result, record in Domains > example.com > DNS Settings will keep source DKIM key and it should look as follows:

CONFIG_TEXT: v=DKIM1; p=OlDKey..;

Re-create the DKIM TXT record from example.com, to keep target server DKIM TXT record
  1. Log in to Plesk

  2. Go to Domains > example.com > Mail Settings

  3. Disable Use DKIM spam protection system to sign outgoing email messages and save.

  4. Enable again Use DKIM spam protection system to sign outgoing email messages and save.

As a result, record in Domains > example.com > DNS Settings will have a new DKIM key and it should look as follows:

CONFIG_TEXT: v=DKIM1; p=NeWkEy..;

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