Applicable to:
- Plesk for Linux
Symptoms
A lot of messages from MAILER-DAEMON@example.com
are stuck in the queue (Tools & Settings > Mail Server Settings > Mail Queue):
The number of such messages is growing exponentially.
The recipient's server (johndoe@example.org
) is not reachable:
# telnet example.org 25
Trying 203.0.113.2...
telnet: connect to address 203.0.113.2: Connection timed out
Cause
Outgoing spam was sending (or being sent at the moment) to the addresses that do not exist or are not reachable at the moment.
Resolution
Warning: The below steps are temporary measures. To manage outbound spam protection settings, refer to the following documentation:
Protection From Outbound Spam
As a workaround, automatic cleaning may be set up as a scheduled task:
-
In Tools & Settings > Scheduled Tasks > Add Task. Fill in as follows:
CONFIG_TEXT: Active
Task type: Run a command
Command: /usr/local/psa/admin/sbin/mailqueuemng --clean
Run: Hourly (set any time)
Description: it flushes the mail queueThe second task:
CONFIG_TEXT: Active
Task type: Run a command
Command: mailq|gawk '/MAILER-DAEMON/ { print $1 }'|/usr/sbin/postsuper -d -
Run: Hourly (set it after two-three minutes past the first one)
Description: delete bounces
Mail Queue will be cleaned once in an hour.
Comments
0 comments
Please sign in to leave a comment.