Applicable to:
- Plesk for Linux
Symptom
- The Imunify, ImunifyAV or Imunify360 extension for Plesk cannot be activated, while a popup that is similar to the following appears when you press on Imunify within the Plesk GUI:
-
One of the following error messages is shown when accessing the Imunify extensions in Plesk:
PLESK_ERROR: Servers limit exceeded for key <KeyNumber>
CONFIG_TEXT: No valid license was found for this Imunify installation. Please upgrade your license to continue using all benefits of the Imunify.
CONFIG_TEXT: WARNING: {"message":"(#_#) You can not register a new server! Right now you have 1 server and your license limit is 1.","type":null,"success":false,"data":null}
-
The following warning is shown while attempting to install the extension manually via command line:
CONFIG_TEXT: WARNING: License is invalid for current server
Register by IP...CONFIG_TEXT: WARNING: {"message":"Servers limit exceeded for key IY1ghpLItqZE8RQbV","type":"validation","success":false,"data":null}
Registration was not successful.
Cause
The Imunify extension license can be used on one Plesk server at a time and the Imunify license checking servers report that you are attempting to use it on two difference Plesk servers simultaneously.
The error generally appears for one of the following reasons:
- More than one Imunify is activated with the same license and activation code
- Imunify has been reinstalled on the same Plesk server, which causes the same server to be registered twice in the Imunify verification database
- Imunify was installed on the newly migrated server, while using the the old Plesk server's IP address
Resolution
If the old Plesk server where Imunify is activated with the mentioned <KeyNumber> is still online, do the following on it in order to unregister Imunify there:
1. Log into your old Plesk server via SSH
2. Execute the following command:
# imunify360-agent unregister
If the old Plesk server is offline already and the issue persists on your new Plesk server, contact CloudLinux Support for further assistance.
For cases where the connected IP address associated with the license was released, try re-registering the license with commands (where <key> is from 'Servers limit exceeded for key' message during manual re-installation):
# imunify360-agent unregister
# imunify360-agent register <key>
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