Applicable to:
- Plesk for Linux
Symptoms
-
Incoming/outgoing emails cannot be sent/delivered, but mail service is configured properly;
-
It is not possible to log into a desktop or mobile mail client, for example below error can occurs:
CONFIG_TEXT: Couldn't verify account
-
It is not possible to send/receive mails;
-
Mail services are up and running and required ports are listened to:
# netstat -nltp | egrep '25|110|143|465|993|995'
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 9007/master
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 1557/dovecot
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 1557/dovecot
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 1557/dovecot
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 1557/dovecot
tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 9007/master -
These ports are not restricted by firewall locally, for example:
# iptables -L -n | egrep '25|110|143|465|993|995'
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:25
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:465
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:110
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:995
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:143
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:993 -
These ports are not available externally:
# nmap -p25,110,143,465,993,995 203.0.113.2
PORT STATE SERVICE
25/tcp filtered smtp
110/tcp filtered pop3
143/tcp filtered imap
465/tcp filtered smtps
587/tcp filtered submission
993/tcp filtered imaps
995/tcp filtered pop3s - Cannot connect Outlook to mail account:
CONFIG_TEXT: error (0x8004210A) : 'The operation timed out waiting for a response from the receiving (POP) server.
Cause
Ports required for mail services are limited with intermediate firewall.
Resolution
Check settings on the intermediate firewall or contact the Hosting Provider to open the following ports:
PLESK_INFO: 25
110
143
465
993
995
Additional info
Which Ports Need To Be Opened for all Plesk Services to Work with a Firewall?
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