Articles in this section

Unable to receive emails in Mail Enable: The message could not be copied to ... It has been bad mailed

Plesk for Windows kb: technical Plesk Obsidian for Windows

Applicable to:

  • Plesk Obsidian for Windows
  • Plesk for Windows

Symptoms

  • Emails are not delivered to Plesk with MailEnable mail server.

  • It is not possible to send email from the server.
  • The %plesk_dir%Mail Servers\Mail Enable\Queues\SF\Outgoing\Messages folder is missing.

  • In %plesk_dir%Mail Servers\Mail Enable\Logging\SMTP\SMTP-Debug-<date>.log is observed that the message was successfully delivered:

    CONFIG_TEXT: ME-I0135: Authenticating User:jdoe@example.com using Authentication Provider Credentials
    ME-I0108: [1112] Relay Granted: Sender has authenticated.
    ME-I0149: [1112] BD5904B9147A4A03A8CF83F8A4984598.MAI was received successfully and delivery thread was initiated

  • The following is shown in %plesk_dir%Mail Servers\Mail Enable\Logging\MTA\MTA-Debug-<date>.log:

    CONFIG_TEXT: ME-MTA-ERROR Internal Error: (Error 3) Message (AD9A862ABBBC418AA7D5EF5A4F805F6C.MAI) could not be transferred from [SMTP] Connector to [SF] Connector. The message could not be copied to C:\plesk\Mail Servers\Mail Enable\QUEUES\SF\Outgoing\Messages\537E8C53A44A4A35BA7DA0ABE8954191.MAI. It has been bad mailed.
    Debug 114: Message (AD9A862ABBBC418AA7D5EF5A4F805F6C.MAI) has been copied to the system BadMail directory

  • In%plesk_dir%Mail Servers\Mail Enable\Queues\SF\Outgoing\there is a file called Messages, which is not a directory.

Cause

The email messages are being received on the server but bad mailed on their way between SMTP and MTA due to a missing directory.

Resolution

  1. Connect to the server via RDP

  2. Create the missing folder %plesk_dir%Mail Servers\Mail Enable\Queues\SF\Outgoing\Messages as shown below:

    Untitled.png

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.