Articles in this section

Creating Plesk backup to remote storage fails: Not enough free disk space to backup selected objects

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • On a Plesk server, creating a backup to remote storage in Tools & Settings > Backup Manager fails:

    PLESK_ERROR: Not enough free disk space to backup selected objects. At least 231208.573798 Mbytes free disk space is required.

    OR

    PLESK_ERROR: Error: There is not enough disk space at /var/lib/psa/dumps to backup creation. At least 945.75 GB free space is required (227.25 GB is available)

  • The option Start the backup only if your server has the sufficient amount of free disk space (this option may significantly increase the backup time) in Tools & Settings > Backup Manager > Backup Settings is enabled.

Cause

The Start the backup only if your server has the sufficient amount of free disk space checkbox in Plesk > Tools and settings > Backup Manager > Settings is enabled.

Having this option enabled makes the calculation of disk space for the drive on which /var/lib/psa/dumps resides mandatory before the backup creation is started.

The calculation assumes that the entire backup would be stored locally on the server instead of being uploaded to a remote storage while the process is ongoing, due to which the backup creation will not be started if the drive on which /var/lib/psa/dumps resides does not have a sufficient amount of free space.

Resolution

Allocate additional disk space to or remove unnecessary files in the Plesk backup location - by default, it is /var/lib/psa/dumps on Linux and %plesk_dir%Backup on Windows.

Alternatively, do the following:

1. Log into Plesk

2. Go to Tools & Settings > Backup Manager > Backup Settings

3. Disable the option Start the backup only if your server has the sufficient amount of free disk space (this option may significantly increase the backup time) to make the Plesk Backup Manager not count overall disk space required for the backup at all.

Additional information

How do backups to remote storage (FTP or cloud) work on a server with Plesk? 

Was this article helpful?

Comments

2 comments
Date Votes
  • I tried disabling the option “Start the backup only if your server has the sufficient amount of free disk space” - it still attempts to write to disk. Unable to write to Google Drive. 

    0
  • Daniel Yordanov maybe a stupid question: but why do I need much more local space that what I define as chunk size for backup files for the remote storage? I set my chunk size to 3 GB but still the backup eats up all 50 GB of the remaining local disk space available. 

    Oh, and btw, the option “Start the backup only if your server has the sufficient amount of free disk space” as defined in the online manual (https://docs.plesk.com/en-US/obsidian/administrator-guide/backing-up-and-restoration/global-backup-settings.59265/) should work even without setting a fixed number for the minimum available space, but it does not. From what I read in the manual, this should happen:

    - if the box is ticked and the field for minimum available local space is empty: plesk calculates the available space and then only starts a backup if the size is smaller than the remaining space. However, this is not possible as the box requires a number for minimum available space. 

    Please make sure that remote backups still work when the remaining local disk space is lower than the size of the largest subscription! 

    And vice versa, make sure that restoring individual files from a (potentially incremental) backup does not require free space in the order of the full backup size!

    0

Please sign in to leave a comment.