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Emails are not sent from a Plesk server with the errors "25: Connection timed out" and "25: Network is unreachable"

Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • Emails from a Plesk server are not sent. The following records appear in /var/log/mailllog:

    CONFIG_TEXT: connect to aspmx.l.google.com[203.0.113.2]:25: Connection timed out
    plesk postfix/smtp[17181]: connect to aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable
    plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[203.0.113.2]:25: Connection timed out
    plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable

  • It is possible to connect to a remote host on port 25 using the telnet utility:

    # telnet alt2.aspmx.l.google.com 25
    ...
    Trying 74.125.28.26...
    Connected to alt2.aspmx.l.google.com.
    Escape character is '^]'.
    220 mx.google.com ESMTP c68si1753439pfa.129 - gsmtp

Cause

A private IP address is used for outgoing emails.

Resolution

  1. Log in to Plesk.

  2. Go to Tools and Settings > Mail Server Settings.

  3. Set Outgoing mail mode to some public IP address.

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