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Auto-reply does not work when SMTP smart host is used in Plesk

Plesk for Windows kb: technical ABT: Group A

Applicable to:

  • Plesk for Windows

Symptoms

  • Plesk service messages (notifications, auto-replies, password reset links) are not sent from the server

  • Error on sending a message with password reset link:

    PLESK_ERROR: Error: Unable to send the secret code: Your domain does not seem to be valid. Could not find MX record for your domain.

  • Errors in Mail Enable logs folder, in SMTP-Activity-<date>.log or SMTP-Debug-<date>.log:

    CONFIG_TEXT: 504 5.5.2 postmaster@localhost: Sender address rejected: need fully-qualified address 32 89 postmaster@localhost Re: Email message
    SMTP-OU 2346778F969647F6AFFF84D4EB584B05.MAI 2040 203.0.113.2 QUIT QUIT 221 2.0.0 Bye 6 15 postmaster@localhost Re: Email message

    OR

    CONFIG_TEXT: SMTP-IN 93F3B59DDD35483EEDC8435AE43CC961.MAI 1044 127.0.0.1 MAIL MAIL FROM: noreply@example.com 501 Your domain does not seem to be valid. Could not find MX record for your domain. 86 52 postmaster@localhost

    OR

    CONFIG_TEXT: SMTP error from remote mail server after MAIL FROM:<postmaster@localhost>: 550 5.1.0 MXIN401 Your Mailfrom Domain localhost is blacklisted here 

    OR

    CONFIG_TEXT: ME-IXXXX: [614671D3F0904C94AAD76C3E72181812.MAI] Remote server returned a response indicating a permanent error. Server Response: (550-Sender verification is required but failed. (ID:550:0:5**550 (server_hostname)): postmaster@localhost)

    OR

    CONFIG_TEXT: Remote server returned a response indicating a permanent error. Server Response: (550-Verification failed for <postmaster@localhost>**550-Unrouteable address**550 Invalid sender <postmaster@localhost>**

  • For external/local SmarterMail server, the following error can be found at C:\SmarterMail\Logs\YYYY.MM.DD-delivery log :

    CONFIG_TEXT: 504 5.5.2 postmaster@localhost: Sender address rejected: need fully-qualified address

Cause

SMTP email relay service provider does not accept emails from postmaster@localhost.

Resolution

Change the mail account that is used as a sender name:

  1. Log in to Plesk
  2. Go to Tools & Settings > External SMTP Server and uncheck the option Use the mail server installed with Plesk and the default mail account created by Plesk.

  3. In the appeared fields, specify a valid mail account that will be used as a sender name. Once done, click OK.

    Screenshot_2018-07-11_External_SMTP_Server_Settings_-Plesk_Onyx_17_8_11_2.png

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