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A migrated database in Plesk cannot be accessed via phpMyAdmin: Access denied for user

Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux

Symptoms

  • Pop-up occurs when a database is accessed via working phpMyAdmin using Domains > example.com > Databases > exampledb > phpMyAdmin link:

    CONFIG_TEXT: Enter the password to log in as the database user example_user.

  • phpMyAdmin shows one of the following errors on attempts to access the database directly:

    CONFIG_TEXT: Connection for example_user as defined in your configuration failed


    CONFIG_TEXT: You probably did not create a configuration file. You might want to use the setup script to create one.

    Error
    MySQL said:

    #1045 - Access denied for user 'exampleuser'@'localhost' (using password: YES)
    mysqli_real_connect(): (HY000/1045): Access denied for user 'exampleuser'@'localhost' (using password: YES)

  • Might be experienced after migration from Cpanel or DirectAdmin

Cause

The expected behavior.
Passwords are encrypted using asymmetrical encryption and cannot be transferred. The password should be recreated in Plesk manually to access phpMyAdmin.

Resolution

Apply one of the solutions below:

Specify the correct password in the pop-up
  1. Log into Plesk

  2. Go to Domains > example.com > Databases > exampledb > phpMyAdmin

  3. Specify the correct password in the pop-up

Specify the new password via Plesk

Warning: In case this database is being used by any application, make sure that the password matches with the one specified during the procedure below.

  1. Log into Plesk
  2. Go to the Domains > example.com > Databases > User Management > example_user
  3. Specify a new password (or click on the Generate button)
  4. Click the OK button
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