Articles in this section

Unable to issue/renew a Let's Encrypt certificate in Plesk: Error creating new account :: "" is not a valid e-mail address

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • A Let's Encrypt certificate cannot be issued for a domain.

  • The following error message appear in /usr/local/psa/admin/logs/panel.log:

    CONFIG_TEXT: ERR [extension/sslit] Failed to renew certificate of domain 'example.com': Invalid response from https://acme-v02.api.letsencrypt.org/acme/new-acct.
    Details:
    Type: urn:ietf:params:acme:error:invalidEmail
    Status: 400
    Detail: Error creating new account :: "" is not a valid e-mail address


    CONFIG_TEXT: ERR [extension/sslit] Failed to renew certificate of domain 'example.com': Invalid response from https://acme-v02.api.letsencrypt.org/acme/new-acct.
    Details:
    Type: urn:ietf:params:acme:error:invalidEmail
    Status: 400
    Detail: Error creating new account :: "" Domain name does not end with a valid public suffix (TLD)

Cause

The email address of the subscription owner is not set at Domains > example.com > Subscription Info (in the right pane) > Subscriber: John Doe > Edit Contact Info (in the right pane):


mceclip0.png

Resolution

  1. Log in to Plesk.

  2. Go to Customers > John Doe > Edit Contact Info (in the right pane) and set an email address for this customer.

    Note: The email address used for Let's Encrypt certificate notifications can be set to another one when issuing a Let's Encrypt certificate.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.