Applicable to:
- Plesk for Linux
Symptoms
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Mail is stuck in the queue when Plesk Email Security extension is installed and errors similar to the following are shown in the file
/var/log/maillog
:CONFIG_TEXT: postfix/error[1634]: 123B3210AB: to=jdoe@example.com, relay=none, delay=0.79, delays=0.79/0/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)
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The Amavis content filter service doesn't return the server greeting:
# telnet 127.0.0.1 10024
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'. -
One of the Amavis service content filter processes is always busy trying to deliver the same email message, reducing significantly the capabilities to manage more emails:
# egrep amavis /var/log/maillog
amavis[7299]: (07299-06-25) Negative SMTP response to data-dot (<jdoe@example.com>): 452 4.2.2 Mailbox full, dt: 572.7 ms
amavis[7299]: (07299-06-25) (!)4CSChbd_n_Pc FWD from jsmith@example.info -> <jdoe@example.com>, BODY=7BIT 452 4.2.2 from MTA(smtp:[127.0.0.1]:10025): 452 4.2.2 Mailbox full
amavis[7299]: (07299-06-25) (!!)TROUBLE: Number of recipients (1) not reduced, abandoning effort, proto: smtp -
Going to Domains > example.com > Mail Accounts shows that the jdoe@example.com mailbox is full
Cause
The destination email address hosted in Plesk has a full mailbox and this causes the Amavis service content filter processes to get stuck.
This behavior has been confirmed as bug with ID #EXTPLESK-5578 and will be resolved permanently in future versions of Plesk and the Plesk Email Security extension.
You may track the progress in the Change Log for Plesk Obsidian.
Resolution
Until the bug is resolved permanently, you may apply the following workaround:
- Open Plesk > Extensions > My Extensions > Plesk Email Security > Open
- Select Server Settings tab and press on Advanced
- Increase the value in the Processes field of the Concurrent Amavis Processes
- Click Save
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Increase the space in the affected mailbox by going to Domains > example.com > Mail Accounts > jdoe@example.com > and increasing the Mailbox size via the Another size option:
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Inform the mailbox user to free up space in the affected mailbox by deleting emails that are no longer necessary on his end
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Resend the deferred emails in Postfix
Note: The mail queue can take some minutes to be processed and you may monitor it by going to Tools & Settings > Mail Server Settings > Mail Queue
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