Applicable to:
- Plesk for Linux
Symptoms
- Plesk Obsidian running on a Linux-based operating system
-
Mail is stuck in the queue when Plesk Email Security extension is installed and errors similar to the following are shown in the file
/var/log/maillog
:CONFIG_TEXT: postfix/error[1634]: 123B3210AB: to=jdoe@example.com, relay=none, delay=0.79, delays=0.79/0/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)
-
The Amavis content filter service doesn't return the server greeting:
# telnet 127.0.0.1 10024
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'. -
One of the Amavis service content filter processes is always busy trying to deliver the same email message, reducing significantly the capabilities to manage more emails:
# egrep amavis /var/log/maillog
amavis[7299]: (07299-06-25) Negative SMTP response to data-dot (<jdoe@example.com>): 452 4.2.2 Mailbox full, dt: 572.7 ms
amavis[7299]: (07299-06-25) (!)4CSChbd_n_Pc FWD from jsmith@example.info -> <jdoe@example.com>, BODY=7BIT 452 4.2.2 from MTA(smtp:[127.0.0.1]:10025): 452 4.2.2 Mailbox full
amavis[7299]: (07299-06-25) (!!)TROUBLE: Number of recipients (1) not reduced, abandoning effort, proto: smtp -
Going to Domains > example.com > Mail Accounts shows that the jdoe@example.com mailbox is full
Cause
The destination email address hosted in Plesk has a full mailbox and this causes the Amavis service content filter processes to get stuck. This has been reported as bug ID EXTPLESK-5578.
Resolution
- Open Plesk > Extensions > My Extensions > Plesk Email Security > Open
- Select Server Settings tab and press on Advanced
- Increase the value in the Processes field of the Concurrent Amavis Processes
- Click Save
-
Resend the deferred emails in Postfix
Note: The mail queue can take some minutes to be processed and you may monitor it by going to Tools & Settings > Mail Server Settings > Mail Queue
-
It's also strongly recommended to increase or free up space in the affected mailbox by going to Domains > example.com > Mail Accounts > jdoe@example.com > and increasing the Mailbox size via the Another size option:
Note: Additionally, you should inform the mailbox user to free up space in the affected mailbox by deleting emails that are no longer necessary on his end
Comments
0 comments
Please sign in to leave a comment.