Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- Incoming emails that are sent to mailboxes for a specific domain that is hosted on a Plesk server are not received
- There is no trace of any incoming emails for that domain within the mail logs of the server
Cause
The affected domain does not have a valid DNS MX record (it may be missing entirely) or has no corresponding A DNS record for that MX record:
# dig @8.8.8.8 +short -t MX example.com +short
10 mail.
# dig @8.8.8.8 +short -t MX example.com +short
(Empty Output)
# dig @8.8.8.8 +short MX example.com
mail.example.com
# dig @8.8.8.8 +short mail.example.com
Empty Output
Resolution
Note: If the nameservers for the domain were changed recently, it is required to wait for the global DNS propagation period (up to 48 hours, but it is usually completed within 8 hours).
If the primary DNS zone of the domain resides on the Plesk server, add a valid MX and corresponding A record within the DNS zone of the affected domain.
If the primary DNS zone of the domain is external and does not reside on the Plesk server, add the appropriate MX record and the corresponding A record within the DNS management panel of the DNS service provider that this domain is using.
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