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Event Viewer shows error: SMTP Exception: The mail service is unavailable: 451 ESMTP MailEnable Service temporarily refused connection

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • The following event is logged in Event Viewer > Plesk:

    SMTP Exception: The mail service is unavailable: 451 ESMTP MailEnable Service temporarily refused connection at 06/18/20 00:55:09 from IP (203.0.113.2) because the server is too busy.

  • Mails may not be received or sent

Cause

The SMTP service configuration limited the number of concurrent inbound connections to the SMTP service.

Resolution

For expected high number of concurrent inbound connections
  1. Connect to the server via RDP
  2. Open MailEnable Admin console > Servers > localhost > Services and Connectors > right-click on the SMTP > Properties > Inbound > Settings next to Advanced Settings
  3. Increase the value for concurrent inbound connections
  4. Go to Service Management and restart MailEnable SMTP service
For DoS attacks
  1. Log into Plesk
  2. Open Tools & Settings > Firewall > Firewall Rules > Add Firewall rule
  3. Add a firewall rule to drop connections to port 25 from the attacker's IP address mentioned in the event viewer (in this example, it is 203.0.113.2)
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