Articles in this section

Failed backups cannot be removed from Backup Manager

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk Obsidian for Linux
  • Plesk Obsidian for Windows
  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Failed backups cannot be removed from a list in Tools & Settings > Backup Manager
  • The backup checkbox is greyed out and can not be selected

Cause

Failed backup task is stuck in the tasks.db database

Resolution

Linux
  1. Connect to the server via SSH

  2. Access the backup tasks database:

    # sqlite3 /usr/local/psa/PMM/tasks/tasks.db

  3. Find the failed task by timestamp and remove it.

    For example, the failed backup session was created 2020-09-01:

    MYSQL_LIN: SELECT * FROM tasks WHERE dump LIKE '%2020-09-01%;

  4. Examine the query output, and remove the task if the session timestamp matches the stuck one:

    MYSQL_LIN: DELETE FROM tasks WHERE id=2;

Windows
  1. Connect to the server via RDP

  2. Download the sqlite3 client from this link and extract it to any convenient location (e.g. C:\sqlite)
  3. Open the command prompt as Administrator and access the backup tasks database

    C:\> "C:\sqlite\sqlite3.exe" "%plesk_dir%PMM\tasks\tasks.db"

  4. Find the failed task by timestamp and remove it.

    For example, the failed backup session was created 2020-09-01:

    MYSQL_WIN: SELECT * FROM tasks WHERE dump LIKE '%2020-09-01%;

  5. Examine the query output, and remove the which has the session timestamp matching the stuck one in GUI:

    MYSQL_WIN: DELETE FROM tasks WHERE id=2;

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.