Plesk for Windows
kb: how-to
Plesk for Linux
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptom
- Domain example.com was created in Plesk using the button Domains > Add Domain.
- After that, the content of the website was transferred to the current server from another Plesk server or added manually.
- When accessing a website in a browser, the Default webpage generated for example.com is displayed, despite that fact, the valid Index file, for example,
index.php
orDefault.aspx
exists in the domain's document root.
Cause
A new empty domain with a default virtual host structure was created before the content of the domain was imported/created.
The Domain Default Page (index.html
file) is automatically deployed during the domain creation. By default, index.html
has priority over other index files. The second index file is not processed due to the fact that it has a lower priority.
In case the issue appears when the domain was moved within the server, contact Support for Root Cause Investigation.
Resolution
In order to increase the priority for another index file over index.html
, perform the following:
On Plesk for Linux
- Log in to Plesk.
- Go to Domains > example.com > Hosting & DNS > Apache & nginx.
- Switch the option Index files to Enter custom value.
- Place the required index file at the beginning of the line, for example:
- Apply changes.
On Plesk for Windows
- Log in to Plesk.
- Go to Domains > example.com > Hosting & DNS > IIS Settings.
- In the field Default documents, change the order of index files and place the required file above the
Index.html
, for example:
- Apply changes.
Note: In case the default index.html
file is not required, it is also possible to rename or delete it in Domains > example.com > File Manager.
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