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Upon restoring Plesk backup email messages show backup restoration time as the time they were received on the Apple mail client

kb: bug kb: fixed Plesk for Linux

Applicable to:

  • Plesk for Linux

Symptoms

  • After restoring a domain from a backup via Plesk > Tools & Settings > Backup Manager, email messages show backup restoration date and time as the time they were received on the Apple mail client.

  • Other mail clients and webmail show the correct date and time when the email messages were received.

Cause

Product issues:

  • #PPPM-10282 Open
  • #PMT-4559 "After migrating mail, actual dates when emails were received are no longer changed to the date of migration on certain mail clients (for example Apple Mail)."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If an update is not possible for some reason you may try the following

workaround
  1. Connect to the server via SSH.

  2. Download this script to fix the email files timestamp by running the command below:

    # wget https://support.plesk.com/hc/en-us/article_attachments/4407730641426/PMT-4559_mtime_update.sh

  3. Give execution permission to the downloaded script file:

    # chmod +x PMT-4559_mtime_update.sh

  4. Run the script with the target mailbox name:

    # ./PMT-4559_mtime_update.sh jdoe@example.com

    Or multiple mailboxes:

    # ./PMT-4559_mtime_update.sh jdoe@example.com janedoe@example.org

  5. After the script execution is finished, log out and log in back to the mail client and check timestamps.

In some cases, Dovecot indexes might also need to be rebuilt. For this, dovecot index files for each affected mail account should be moved from the default directory.

Note: It should be done separately for each affected account. In the example below, index files are moved for the account jdoe existing for the domain example.com (jdoe@example.com):

  1. Create the destination directory for the index files to be moved:

    # mkdir -p /root/indexback/jdoe

  2. Move the Dovecot index files:

    # mv /var/qmail/mailnames/example.com/jdoe/Maildir/dovecot.index* /root/indexback/jdoe/

  3. Log out and log in back to the mail client.

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Comments

4 comments
Date Votes
  • Hello,

    I write here because I didnt find any threat related to "Redownloading of old mails via pop3 after migration Plesk to Plesk"

    Last week I migrate Plesk server (CentOS7, Plesk 18.0.56, Postfix, Dovecot) to Plesk server (Almalinux8, Plesk 18.0.56, Postfix, Dovecot) with "Migration & Transfer Manager" At the end (after migration) IP were stays the same. After migration all pop3 email account redownoaded all messages. Do you know about this problem? I found only this information https://talk.plesk.com/threads/redownloading-of-old-mails-after-migration.336590/

    Regards,

    0
  • We are migrating away from Plesk because of bugs like #PPPM-10282 which have been open for years with no resolution. This particular bug ruined everyone's mailbox for days before we understood what had happened.

    0
  • By the way, blaming primarily Apple mail client is nonsense. We observed the behavior also in Thunderbird and Outlook.

    0
  • An addition to the “Dovecot indexes might also need to be rebuilt” part of the workaround: the command indicated here only moves (and thus rebuilds) the cache of the inbox. If you have subfolders, their caches also need to be rebuilt by removing, or moving or renaming, their cache files. They are are located in /var/qmail/mailnames/example.com/jdoe/Maildir/.Directory name

    0

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