Articles in this section

Cannot send or receive email on a Linux Plesk server: delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • Sending and receiving email fails with errors such as the following visible in /var/log/maillog:

    CONFIG_TEXT: postfix/error[14359]: 3936F15A365: to=example@example.com, relay=none, delay=0.32, delays=0.32/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    CONFIG_TEXT: Message: (!)_DIE: Suicide in child_init_hook: BDB can't connect db env. at /var/spool/amavisd/db: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch, Operation not permitted. at (eval 79) line 338.

    CONFIG_TEXT: postfix/error[2024009]: 7F23A21FEC: to=<example@example.com>, relay=none, delay=0.26, delays=0.26/0/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)

    CONFIG_TEXT: amavis[4070245]: (!!)TROUBLE in child_init_hook: BDB can't connect db env. at /var/spool/amavisd/db: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch, Operation not permitted. at /usr/share/perl5/vendor_perl/Amavis/DB.pm line 82.

  • Amavis is shown as active, however with many errors such as the following:

    # systemctl status amavis*
    Active: active (running) since Wed 2020-01-01 12:00:00 EST; 55min ago

Cause

The Amavis (spam filter service) got stuck and needs to be restarted.

Resolution

  1. Connect to the server via SSH
  2. Restart the Amavis service by executing the following command:

    # systemctl restart amavis*

  3. Requeue all deferred outgoing messages only:

    # postsuper -r deferred

  4. Retry delivery for all requeued emails immediately:

    # postqueue -f

Note: If the steps above do not resolve the issue, try using the steps from Unable to receive email with Plesk Email Security extension installed: (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=emailsecurity;mysql_socket=/var/run/mysqld/mysqld.sock'

Was this article helpful?

Comments

4 comments
Date Votes
  • This doesn't work, the only solution was to edit /etc/amavisd/email-security.conf  and modify this line:

    @lookup_sql_dsn =(
        ["DBI:mysql:database=emailsecurity;mysql_socket=/var/run/mysqld/mysqld.sock", "es_ipezbcv", "7P0c_Nd2!r1t^YIsR3"]
    );

    to:

    @lookup_sql_dsn =(
        ["DBI:mysql:database=emailsecurity;mysql_socket=/var/lib/mysql/mysql.sock", "es_ipezbcv", "7P0c_Nd2!r1t^YIsR3"]
    );

    Restart amavis service afterwards:

    service amavis restart

    followed by processing the queued emails:

    postsuper -r ALL

     

    0
  • I have the same problem, I don't have any service with the name amavisd-new, I did what Adrian Cherciu said but the problem persists.

    0
  • I've updated my reply, please do the rest of the commands, I just assumed would be common sense, sorry :) 

    0
  • I’ve been investigating every time the “BDB can’t connect to db” error occurs, and I’ve discovered that it happens when glibc is updated via Plesk’s auto-update feature.
    It appears this issue has been reported to Amavis.


    https://gitlab.com/amavis/amavis/-/work_items/136

    0

Please sign in to leave a comment.